Solution:This setup requires internet information server 5.1 or higher

 

Introduction

Few days ago, somebody ask me a question on my forum. His question was :

i have just created my Asp.Net WebSetup. But the problem is that now it is giving error something like this : This setup requires internet information server 5.1 or higher. How to solve this problem.

So today i decided to describe, How to solve this error which occurs during installation.

Solution

As the error is saying that you need to install Internet Information Server (IIS) or higher.

You can download it form <a href="http://www.microsoft.com/en-in/download/details.aspx?id=34679">here</a>.

Install it and try to run your setup file again. Hope the problem will be solved.

If you still got the error, then follow the below steps :

Step 1.

Open control Panel > Programs > Turn windows features on or off.

Step 2.

You can see windows features dialog.

Expand Internet Information Services and make sure all the features are cheked under "Web Management Tools" and "World Wide Web Services". Press OK Button.

ScreenShot

Step 3.

Now try to run both the installation files one by one. Your problem will be solved.

Give your Valuable Comments.
comments powered by Disqus
 
Follow me on twitter
About Me
Harpreet Singh
I began programming with C++ when i was 17. Then at the middle of my study .NET came. Then I began to read C# and VB.NET. By the time i learnt SQL and ASP.NET, and developed some websites such as news portals that are active now. Currently i am running my own Software company.
More Articles